CVE-2026-27745: SPIP interface_traduction_objets · Code Injection
Affects SPIP interface_traduction_objetsSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 2.2.2 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade interface_traduction_objets and spip/interface_traduction_objets to 2.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SPIPinterface_traduction_objets | Affected
| Fixed in
|
Packagistspip/interface_traduction_objetspkg:composer/spip/interface_traduction_objetsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-27745, organizations should immediately upgrade the interface_traduction_objets plugin to version 2.2.2 or later where the vulnerability is patched. In addition, implement strict input validation and sanitization on all user-supplied data, especially data incorporated into hidden form fields. Review and harden SPIP's template processing configurations to ensure output filtering cannot be bypassed by special field prefixes. Limit editor-level privileges to trusted users and enforce strong authentication mechanisms such as multi-factor authentication to reduce the risk of account compromise. Regularly audit user activities and monitor logs for suspicious behavior indicative of exploitation attempts. Employ web application firewalls (WAFs) with custom rules to detect and block injection patterns targeting SPIP templates. Finally, maintain an incident response plan tailored to web server compromises to quickly contain and remediate any exploitation.
Description
The SPIP interface_traduction_objets plugin versions prior to 2.2.2 contain an authenticated remote code execution vulnerability in the translation interface workflow. The plugin incorporates untrusted request data into a hidden form field that is rendered without SPIP output filtering. Because fields prefixed with an underscore bypass protection mechanisms and the hidden content is rendered with filtering disabled, an authenticated attacker with editor-level privileges can inject crafted content that is evaluated through SPIP's template processing chain, resulting in execution of code in the context of the web server.
References
- chocapikk.com/posts/2026/spip-plugins-vulnerabilities/ (opens in a new tab)
- blog.spip.net/Mise-a-jour-de-securite-sortie-de-SPIP-4-4-10.html (opens in a new tab)
- plugins.spip.net/interface_traduction_objets (opens in a new tab)
- git.spip.net/spip-contrib-extensions/interface_traduction_objets/-/commit/db3417b7811774f04c3ff191ca1737fe660ef0be (opens in a new tab)
- vulncheck.com/advisories/spip-interface-traduction-objets-authenticated-rce (opens in a new tab)