Skip to main content
VulnerabilityPublished

CVE-2026-27801: dani-garcia vaultwarden · Improper Restriction of Excessive Authentication Attempts

Affects dani-garcia vaultwardenSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.0 Medium : upgrade to 1.35.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.35.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vaultwarden and github/dani-garcia/vaultwarden to 1.35.0.

Affected software

ProductAffectedFixed in
dani-garciavaultwardenAffected
  • <1.35.0
Fixed in
  • 1.35.0
crates.iogithub/dani-garcia/vaultwardenpkg:cargo/github/dani-garcia/vaultwardenOther threatsAffected
  • <1.35.0
Fixed in
  • 1.35.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations and users should immediately upgrade Vaultwarden to version 1.35.0 or later, where the 2FA bypass has been fixed. Additionally, administrators should audit existing user accounts for suspicious activity, especially focusing on accounts with admin or owner privileges in organizations. Implementing strict monitoring and alerting on sensitive actions such as vault deletions or API key accesses can help detect exploitation attempts. It is also advisable to enforce strong authentication policies, including the use of hardware-based 2FA tokens where possible, and to review access logs regularly. For environments where immediate upgrade is not feasible, restricting network access to Vaultwarden instances and employing additional external access controls can reduce exposure. Finally, educating users about credential security and monitoring for compromised credentials can help prevent attackers from gaining initial authenticated access.

Description

Vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwarden_rs. Vaultwarden versions 1.34.3 and prior are susceptible to a 2FA bypass when performing protected actions. An attacker who gains authenticated access to a user’s account can exploit this bypass to perform protected actions such as accessing the user’s API key or deleting the user’s vault and organisations the user is an admin/owner of . This issue has been patched in version 1.35.0.

References

Community reviews

Loading reviews…