CVE-2026-27815: everest-core · Out-of-bounds Write
Affects everest-coreSource CVE Database V5
Public exploit available · CVSS 5.5 Medium : upgrade to 2026.02.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.02.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade everest-core and everest/everest-core to 2026.02.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| EVeresteverest-core | Affected
| Fixed in
|
GitHubeverest/everest-corepkg:github/everest/everest-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch fixing this vulnerability is available in EVerest everest-core version 2026.02.0. Users should upgrade to this version or later to remediate the issue. Since this is not a cloud service, remediation depends on applying the vendor's patch. Patch status is confirmed by the vendor advisory information.
Description
CVE-2026-27815 is a medium severity vulnerability in the EVerest everest-core EV charging software stack prior to version 2026.02.0. It involves an out-of-bounds write caused by copying a variable-length payment_options list into a fixed-size array of length 2 without bounds checking. This occurs in the ISO15118_chargerImpl::handle_session_setup function. Since schema validation is disabled by default, oversized MQTT command payloads can trigger this vulnerability, potentially corrupting adjacent EVSE state or causing the process to crash. A patch addressing this issue is included in version 2026.02.0.