Skip to main content
VulnerabilityPublished

CVE-2026-27891: NeoRazorX facturascripts · Improper Input Validation

Affects NeoRazorX facturascriptsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 2026.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade facturascripts and neorazorx/facturascripts to 2026.1.

Affected software

ProductAffectedFixed in
NeoRazorXfacturascriptsAffected
  • <2026.1
Fixed in
  • 2026.1
GitHubneorazorx/facturascriptspkg:github/neorazorx/facturascriptsOther threatsAffected
  • <2026.1
Fixed in
  • 2026.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to FacturaScripts version 2026.1 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are documented. Patch status is not explicitly confirmed in the vendor advisory, but the fix is included in version 2026.1.

Description

FacturaScripts versions 2026 and below contain a critical vulnerability in the Plugins::add() function that allows a Zip Slip attack via improper validation of file paths in uploaded ZIP archives. This flaw enables an attacker to perform arbitrary file writes and remote code execution by overwriting sensitive PHP files outside the intended plugins directory. The vulnerability arises because the testZipFile function only checks for a single root folder but does not sanitize file paths within that folder, allowing path traversal sequences like .. /.. / to escape the directory. This issue is fixed in version 2026.1.

References

Community reviews

Loading reviews…