Skip to main content
VulnerabilityPublished

CVE-2026-27971: QwikDev qwik · Deserialization of Untrusted Data

Affects QwikDev qwikSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 9.2 Critical : upgrade to 1.19.1 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
5.4% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.19.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Mar 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade qwik and qwikdev/qwik to 1.19.1.

Affected software

ProductAffectedFixed in
QwikDevqwikAffected
  • <1.19.1
Fixed in
  • 1.19.1
npmqwikdev/qwikpkg:npm/qwikdev/qwikOther threatsAffected
  • <1.19.1
Fixed in
  • 1.19.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-27971, organizations should immediately upgrade all instances of the Qwik framework to version 1.19.1 or later, where the vulnerability is patched. If immediate patching is not feasible, temporarily disabling or restricting the use of require() at runtime in server environments can reduce exposure. Implement strict input validation and sanitization on all RPC endpoints to prevent malicious payloads from being processed. Employ runtime application self-protection (RASP) or web application firewalls (WAFs) with custom rules to detect and block suspicious deserialization attempts or anomalous RPC requests. Conduct thorough code reviews and audits of server-side deserialization logic to ensure no unsafe patterns remain. Monitor server logs and network traffic for unusual activity indicative of exploitation attempts. Additionally, isolate critical services and apply the principle of least privilege to limit the potential damage of a successful exploit. Regularly update dependencies and maintain an inventory of software components to quickly identify vulnerable versions. Finally, educate development teams about secure deserialization practices and the risks of exposing require() in server-side JavaScript environments.

Description

Qwik is a performance focused javascript framework.qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

References

Community reviews

Loading reviews…