Skip to main content
VulnerabilityPublished Updated

CVE-2026-28280: jmpsec osctrl · Cross-site Scripting

Affects jmpsec osctrlSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 0.5.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.5.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade osctrl and jmpsec/osctrl to 0.5.0.

Affected software

ProductAffectedFixed in
jmpsecosctrlAffected
  • <0.5.0
Fixed in
  • 0.5.0
GitHubjmpsec/osctrlpkg:github/jmpsec/osctrlOther threatsAffected
  • <0.5.0
Fixed in
  • 0.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations should upgrade osctrl to version 0.5.0 or later, where the issue is fixed. Until an upgrade is possible, restrict query-level permissions strictly to trusted users only, minimizing the attack surface. Implement monitoring and alerting on the on-demand query list for suspicious or unexpected JavaScript payloads. Conduct regular audits of user accounts to detect unauthorized administrators or users with query-level permissions. Employ Content Security Policy (CSP) headers to limit the execution of inline scripts and reduce the impact of XSS attacks. Educate users, especially administrators, to be cautious when interacting with query lists and to report unusual behavior. Additionally, consider isolating the osctrl management interface within a secure network segment to limit exposure. Finally, review and harden session management and CSRF protections to reduce the risk of token theft and privilege escalation.

Description

osctrl is an osquery management solution. Prior to version 0.5.0, a stored cross-site scripting (XSS) vulnerability exists in the `osctrl-admin` on-demand query list. A user with query-level permissions can inject arbitrary JavaScript via the query parameter when running an on-demand query. The payload is stored and executes in the browser of any user (including administrators) who visits the query list page. This can be chained with CSRF token extraction to escalate privileges and take actions as the logged in user. An attacker with query-level permissions (the lowest privilege tier) can execute arbitrary JavaScript in the browsers of all users who view the query list. Depending on their level of access, it can lead to full platform compromise if an administrator executes the payload. The issue is fixed in osctrl `v0.5.0`. As a workaround, restrict query-level permissions to trusted users, monitor query list for suspicious payloads, and/or review osctrl user accounts for unauthorized administrators.

References

Community reviews

Loading reviews…