CVE-2026-28780: Apache HTTP Server · Heap-based Buffer Overflow
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical · fixed in 2.4.67 : patch Apache HTTP Server as a priority.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.67
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
AI-suggested
A fix is available in Apache HTTP Server version 2.4.67. Users should upgrade to this version to remediate the vulnerability. Red Hat has issued security advisories and updates for affected products, including Red Hat JBoss Core Services Apache HTTP Server 2.4.62 Service Pack 4. Applying these vendor-provided updates will mitigate the issue. No additional mitigation steps are indicated by the vendor advisories.
Description
Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
References
- httpd.apache.org/security/vulnerabilities_24.html (opens in a new tab)
- openwall.com/lists/oss-security/2026/05/05/9 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-28780 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2466913 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28780.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:27200 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:47046 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:21433 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:22140 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36846 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36831 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36373 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:21391 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:27201 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:62165 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:66323 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:67152 (opens in a new tab)