Skip to main content
VulnerabilityPublished

CVE-2026-40075: openmrs-core · Path Traversal

Affects openmrs-coreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High · fixed in 2.7.8 : patch openmrs-core soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.8
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
openmrsopenmrs-coreAffected
  • <=2.7.8
  • >=2.8.0 <=2.8.5
Fixed in–
GitHubopenmrs/openmrs-corepkg:github/openmrs/openmrs-coreOther threatsAffected
  • <=2.7.8
  • >=2.8.0 <=2.8.5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade openmrs-core to a fixed version: any version after 2.7.8 in the 2.7.x branch or version 2.8.6 and later. Additionally, ensure that the Apache Tomcat server is updated to version 8.5.31 or later, which provides container-level mitigation against the path traversal bypass. If upgrading openmrs-core is not immediately possible, upgrading Tomcat to a patched version can reduce risk. Patch status is not explicitly stated in the vendor advisory, but the fix is included in the specified versions. No other mitigations are indicated.

Description

OpenMRS Core versions 2.7.8 and earlier, and 2.8.0 through 2.8.5, contain a path traversal vulnerability in the /openmrs/moduleResources/{moduleid} endpoint. This endpoint serves static resources for the login page and is unauthenticated. The vulnerability arises because the ModuleResourcesServlet constructs filesystem paths from user input without proper normalization or boundary checks, allowing attackers to read arbitrary files on the server. Exploitation requires the server to run on Apache Tomcat versions prior to 8.

References

Community reviews

Loading reviews…