Skip to main content
VulnerabilityPublished

CVE-2026-29140: SEPPmail Secure Email Gateway · Improper Certificate Validation

Affects SEPPmail Secure Email GatewaySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 15.0.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 15.0.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:H/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade SEPPmail Secure Email Gateway to 15.0.3.

Affected software

ProductAffectedFixed in
SEPPmailSecure Email GatewayAffected
  • <15.0.3
Fixed in
  • 15.0.3

AI-suggested

Since the product is not a cloud service, remediation depends on applying vendor-provided updates. If you cannot patch yet, users should exercise caution with S/MIME certificates and consider additional email security controls if feasible.

Description

CVE-2026-29140 is a high-severity vulnerability in SEPPmail Secure Email Gateway versions before 15.0.3. It involves improper certificate validation (CWE-295) that allows an attacker to insert attacker-controlled certificates into S/MIME signatures. This can cause the system to use these malicious certificates for encrypting future communications to the victim. The vulnerability has a CVSS 4.0 base score of 7.7, indicating a significant risk. The product is not a cloud service, so remediation depends on vendor patching of on-premises software.

References

Community reviews

Loading reviews…