CVE-2026-33633: kovidgoyal kitty · Heap-based Buffer Overflow
Affects kovidgoyal kittySource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 0.47.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.47.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade kitty and kovidgoyal/kitty to 0.47.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| kovidgoyalkitty | Affected
| Fixed in
|
GitHubkovidgoyal/kittypkg:github/kovidgoyal/kittyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade kitty to version 0.47.0 or later, where this heap-based buffer overflow vulnerability has been fixed. If you cannot patch yet, restrict or monitor processes that can write to the terminal's stdin to reduce exposure. Patch status is confirmed fixed in the official release 0.47.0.
Description
Kitty terminal versions 0.46.2 and below contain a heap-based buffer overflow vulnerability in the load_image_data() function. This flaw is triggered by a specially crafted APC graphics protocol command with a PNG format declaration whose payload exceeds twice the initial buffer capacity. The vulnerability allows any process that can write to the terminal's stdin to crash kitty immediately, causing denial of service. Additionally, the overflow is attacker-controlled in length and content, which may lead to remote code execution. This issue has been fixed in version 0.47.0.