CVE-2026-29169: Apache HTTP Server · NULL Pointer Dereference
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 2.4.66 : patch Apache HTTP Server soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.66
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
AI-suggested
Users should upgrade to Apache HTTP Server version 2.4.66 or later, which addresses this vulnerability. If upgrading is not immediately possible, removing the mod_dav_lock module is recommended to prevent exploitation. Patch status is not explicitly confirmed in the advisory, but the recommendation to upgrade to 2.4.66 indicates a fix is available in that version.
Description
CVE-2026-29169 is a high-severity vulnerability in Apache HTTP Server versions 2.4.66 and earlier involving a NULL pointer dereference in the mod_dav_lock module. This flaw may allow an attacker to crash the server by sending a malicious request. The mod_dav_lock module is not used internally by mod_dav or mod_dav_fs, and its primary known use was with mod_dav_svn from Apache Subversion versions earlier than 1.2.0. Users are advised to upgrade to Apache HTTP Server version 2.4.66 or later, or alternatively remove the mod_dav_lock module to mitigate the issue.