Skip to main content
VulnerabilityPublished Updated

CVE-2026-30238: Intermesh groupoffice · Cross-site Scripting

Affects Intermesh groupofficeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium · fixed in 26.0.10 : update Intermesh groupoffice when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.0.10, 25.0.88, 6.8.155
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade groupoffice and intermesh/groupoffice to 26.0.10, 25.0.88 or 6.8.155.

Affected software

ProductAffectedFixed in
IntermeshgroupofficeAffected
  • <26.0.10
Fixed in
  • 26.0.10
IntermeshgroupofficeAffected
  • <25.0.88
Fixed in
  • 25.0.88
IntermeshgroupofficeAffected
  • <6.8.155
Fixed in
  • 6.8.155
GitHubintermesh/groupofficepkg:github/intermesh/groupofficeOther threatsAffected
  • <6.8.155
  • <25.0.88
  • <26.0.10
Fixed in
  • 6.8.155
  • 25.0.88
  • 26.0.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade GroupOffice to versions 6.8.155, 25.0.88, or 26.0.10 or later, where the vulnerability has been patched. Until upgrades can be applied, administrators should consider implementing web application firewall (WAF) rules to detect and block suspicious requests containing Base64-encoded payloads in the 'f' parameter or attempts to inject script tags. User education to recognize and avoid clicking suspicious links can reduce the risk of exploitation. Additionally, enforcing Content Security Policy (CSP) headers that restrict inline script execution and limit sources of executable scripts can mitigate the impact of XSS attacks. Regularly auditing and monitoring web server logs for anomalous requests targeting the vulnerable parameter can help identify attempted exploitation. Finally, ensure that session management employs secure flags (HttpOnly, Secure) to reduce the impact of stolen cookies.

Description

Group-Office is an enterprise customer relationship management and groupware tool. Prior to versions 6.8.155, 25.0.88, and 26.0.10, there is a reflected XSS vulnerability in GroupOffice on the external/index flow. The f parameter (Base64 JSON) is decoded and then injected into an inline JavaScript block without strict escaping, allowing </script><script>...</script> injection and arbitrary JavaScript execution in the victim's browser. This issue has been patched in versions 6.8.155, 25.0.88, and 26.0.10.

References

Community reviews

Loading reviews…