Skip to main content
VulnerabilityPublished

CVE-2026-30862: appsmithorg appsmith · Cross-site Scripting

Affects appsmithorg appsmithSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.96 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.96
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade appsmith and appsmithorg/appsmith to 1.96.

Affected software

ProductAffectedFixed in
appsmithorgappsmithAffected
  • <1.96
Fixed in
  • 1.96
GitHubappsmithorg/appsmithpkg:github/appsmithorg/appsmithOther threatsAffected
  • <1.96
Fixed in
  • 1.96

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-30862, organizations should immediately upgrade Appsmith to version 1.96 or later, where the vulnerability is patched. Prior to upgrading, restrict access to the 'Invite Users' feature to trusted users only and monitor usage closely. Implement strict input validation and sanitization controls on all user-generated content, especially in components rendering HTML or React elements. Employ Content Security Policy (CSP) headers to reduce the impact of potential XSS attacks by restricting script execution sources. Conduct regular security audits and penetration testing focused on web application input handling and privilege escalation paths. Educate system administrators about the risks of interacting with untrusted user inputs and the importance of cautious API call execution. Additionally, consider implementing multi-factor authentication (MFA) for administrative accounts to reduce the risk of account takeover. Maintain up-to-date backups and incident response plans to quickly recover from potential compromises.

Description

Appsmith is a platform to build admin panels, internal tools, and dashboards. Prior to 1.96, a Critical Stored XSS vulnerability exists in the Table Widget (TableWidgetV2). The root cause is a lack of HTML sanitization in the React component rendering pipeline, allowing malicious attributes to be interpolated into the DOM. By leveraging the "Invite Users" feature, an attacker with a regular user account (user@gmail.com) can force a System Administrator to execute a high-privileged API call (/api/v1/admin/env), resulting in a Full Administrative Account Takeover. This vulnerability is fixed in 1.96.

References

Community reviews

Loading reviews…