CVE-2026-30917: weirdgloop mediawiki-extensions-Bucket · Cross-site Scripting
Affects weirdgloop mediawiki-extensions-BucketSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.1.1 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:L/SI:L/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 9 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade mediawiki-extensions-Bucket and weirdgloop/mediawiki-extensions-Bucket to 2.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| weirdgloopmediawiki-extensions-Bucket | Affected
| Fixed in
|
GitHubweirdgloop/mediawiki-extensions-Bucketpkg:github/weirdgloop/mediawiki-extensions-BucketOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-30917, organizations should immediately upgrade the weirdgloop MediaWiki extension Bucket to version 2.1.1 or later, where the vulnerability is fixed. If upgrading is not immediately feasible, implement strict input validation and output encoding on all Bucket table fields of PAGE type to neutralize potentially malicious scripts. Restrict access to Bucket namespace pages to trusted users only, employing role-based access controls and network segmentation to limit exposure. Employ Content Security Policy (CSP) headers to reduce the impact of any injected scripts by restricting the sources from which scripts can be loaded and executed. Regularly audit MediaWiki extensions and configurations for security compliance and monitor logs for unusual activity indicative of exploitation attempts. Educate users about the risks of XSS and encourage cautious behavior when interacting with MediaWiki content. Finally, maintain an up-to-date inventory of MediaWiki extensions and versions deployed to ensure timely application of security patches and updates.
Description
Bucket is a MediaWiki extension to store and retrieve structured data on articles. Prior to 2.1.1, a stored XSS can be inserted into any Bucket table field that has a PAGE type, which will execute whenever a user views that table's corresponding Bucket namespace page. This vulnerability is fixed in 2.1.1.
References
- github.com/weirdgloop/mediawiki-extensions-Bucket/security/advisories/GHSA-8jrp-37wc-5v7c (opens in a new tab)
- github.com/weirdgloop/mediawiki-extensions-Bucket/commit/46ec08876ba9064987f20e8f42690854202a73ff (opens in a new tab)
- github.com/weirdgloop/mediawiki-extensions-Bucket/commit/cba9cf9c8751e9f3e6d559f44cadc39b84f7bff6 (opens in a new tab)