Skip to main content
VulnerabilityPublished

CVE-2026-30950: Significant-Gravitas AutoGPT · Missing Authorization

Affects Significant-Gravitas AutoGPTSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 0.6.51 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.51
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade AutoGPT and significant-gravitas/AutoGPT to 0.6.51.

Affected software

ProductAffectedFixed in
Significant-GravitasAutoGPTAffected
  • >=0.6.36 <0.6.51
Fixed in
  • 0.6.51
GitHubsignificant-gravitas/AutoGPTpkg:github/significant-gravitas/AutoGPTOther threatsAffected
  • <0.6.51 >=0.6.36
Fixed in
  • 0.6.51

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade AutoGPT to version 0.6.51 or later, where this authorization bypass vulnerability has been patched. No other mitigation is indicated or required as the fix is available in the official release.

Description

AutoGPT versions 0.6.36 through 0.6.50 contain a missing authorization vulnerability that allows authenticated users to hijack other users' sessions. The PATCH /sessions/{session_id}/assign-user endpoint does not verify session ownership, enabling attackers who know another user's session_id to reassign that session to themselves. This lets the attacker read messages in the hijacked session and lock out the legitimate user. The vulnerability is fixed in version 0.6.51.

References

Community reviews

Loading reviews…