Skip to main content
VulnerabilityPublished

CVE-2026-30972: parse-server · Improper Control of Interaction Frequency

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 9.5.2-alpha.10 or 8.6.23 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.2-alpha.10, 8.6.23
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parse-server to 9.5.2-alpha.10 or 8.6.23; parse-community/parse-server to 8.6.23.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.5.2-alpha.10
Fixed in
  • 9.5.2-alpha.10
parse-communityparse-serverAffected
  • <8.6.23
Fixed in
  • 8.6.23
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.23
Fixed in
  • 8.6.23

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The most effective mitigation is to upgrade parse-server to version 9.5.2-alpha.10 or later, or 8.6.23 or later, where the batch request endpoint properly enforces rate limiting on sub-requests. Until upgrades can be applied, organizations should consider implementing external rate limiting or API gateway controls that inspect and limit batch requests as a whole and their sub-requests. Monitoring and alerting on unusual batch request volumes or patterns can help detect exploitation attempts. Additionally, restricting access to the batch endpoint to trusted clients or requiring authentication can reduce exposure. Reviewing and tightening resource quotas and backend service limits can mitigate the impact of potential abuse. Network-level protections such as WAF rules to detect and throttle suspicious batch request payloads may also be beneficial. Finally, educating developers and administrators about this vulnerability and ensuring timely patch management is critical.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior o 9.5.2-alpha.10 and 8.6.23, Parse Server's rate limiting middleware is applied at the Express middleware layer, but the batch request endpoint (/batch) processes sub-requests internally by routing them directly through the Promise router, bypassing Express middleware including rate limiting. An attacker can bundle multiple requests targeting a rate-limited endpoint into a single batch request to circumvent the configured rate limit. Any Parse Server deployment that relies on the built-in rate limiting feature is affected. This vulnerability is fixed in 9.5.2-alpha.10 and 8.6.23.

References

Community reviews

Loading reviews…