CVE-2026-3145: libvips · Memory Corruption
Affects libvipsSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:XExploitation evidence
Disclosed: evidence found.
CVE published 25 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| libvips | Affected
| Fixed in– |
GitHublibvips/libvipspkg:github/libvips/libvipsOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:libvips:libvips:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-3145, organizations should apply the official patch identified by commit d4ce337c76bff1b278d7085c3c4f4725e3aa6ece to update libvips to a fixed version beyond 8.18.0. If immediate patching is not feasible, restrict local access to systems running libvips to trusted users only, minimizing the risk of exploitation. Employ strict access controls and monitoring on systems where libvips is deployed, especially in shared or multi-tenant environments. Conduct code reviews and input validation on any custom integrations that invoke libvips matrix loading functions to detect and prevent malformed inputs. Additionally, implement runtime protections such as memory corruption mitigations (e.g., ASLR, DEP) and sandboxing to limit the impact of potential exploitation. Regularly audit and update all dependencies to ensure vulnerabilities are promptly addressed. Finally, maintain comprehensive logging and alerting to detect anomalous local activity that could indicate exploitation attempts.
Description
A flaw has been found in libvips up to 8.18.0. The affected element is the function vips_foreign_load_matrix_file_is_a/vips_foreign_load_matrix_header of the file libvips/foreign/matrixload.c. Executing a manipulation can lead to memory corruption. The attack needs to be launched locally. This patch is called d4ce337c76bff1b278d7085c3c4f4725e3aa6ece. A patch should be applied to remediate this issue.
References
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- github.com/libvips/libvips/issues/4876 (opens in a new tab)
- github.com/libvips/libvips/pull/4888 (opens in a new tab)
- github.com/libvips/libvips/commit/d4ce337c76bff1b278d7085c3c4f4725e3aa6ece (opens in a new tab)
- github.com/libvips/libvips/ (opens in a new tab)