Skip to main content
VulnerabilityPublished

CVE-2026-3147: libvips · Heap-based Buffer Overflow

Affects libvipsSource CVE Database V5

0
Compare

Public exploit available · CVSS 4.8 Medium.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
libvipsAffected
  • 8.0 – 8.18.0
19 affected builds
Fixed in–
GitHublibvips/libvipspkg:github/libvips/libvipsOther threatsAffected
  • 8.0 – 8.18.0
19 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:libvips:libvips:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-3147, organizations should promptly apply the official patch identified by commit b3ab458a25e0e261cbd1788474bbc763f7435780 to all affected libvips versions up to 8.18.0. Additionally, restrict local access to systems running vulnerable libvips instances by enforcing strict access controls and monitoring for unauthorized local activity. Employ application whitelisting and privilege separation to limit the impact of potential exploitation. Validate and sanitize all CSV inputs rigorously before processing to reduce the risk of malformed data triggering the overflow. Consider upgrading to libvips versions beyond 8.18.0 where the vulnerability is resolved. Implement runtime protections such as heap canaries and address space layout randomization (ASLR) to mitigate exploitation impact. Regularly audit and monitor logs for unusual behavior related to CSV processing components. Finally, educate local users about the risks of executing untrusted files on systems running libvips.

Description

A vulnerability was found in libvips up to 8.18.0. This affects the function vips_foreign_load_csv_build of the file libvips/foreign/csvload.c. The manipulation results in heap-based buffer overflow. The attack requires a local approach. The exploit has been made public and could be used. The patch is identified as b3ab458a25e0e261cbd1788474bbc763f7435780. It is advisable to implement a patch to correct this issue.

References

Community reviews

Loading reviews…