Skip to main content
VulnerabilityPublished Updated

CVE-2026-3178: Name Directory (WordPress plugin) · Cross-site Scripting

Affects Name Directory (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High · fixed in 1.30.3 : patch Name Directory (WordPress plugin) soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.30.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
jeroenpeters1986Name DirectoryAffected
  • <=1.32.1
Fixed in–

AI-suggested

Partial patches exist in versions 1.30.3 and 1.32.1; however, the vulnerability remains in all versions up to and including 1.32.1. Since no definitive patch link or full fix is confirmed, users should monitor the vendor's advisories for an official fix. Until a complete patch is available, consider disabling or removing the Name Directory plugin or applying custom input sanitization and output escaping as a temporary mitigation.

Description

The Name Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'name_directory_name' parameter in all versions up to, and including, 1.32.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in versions 1.30.3 and 1.32.1.

References

Community reviews

Loading reviews…