CVE-2026-31828: parse-server · LDAP Injection
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 6.0 Medium : upgrade to 9.5.2-alpha.13 or 8.6.26 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.5.2-alpha.13, 8.6.26
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.5.2-alpha.13 or 8.6.26; parse-community/parse-server to 8.6.26.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade parse-server to version 9.5.2-alpha.13 or later, or 8.6.26 or later, where the vulnerability is fixed.
- If immediate upgrade is not possible, implement input validation and sanitization on authData.id to escape LDAP special characters before they are used in queries.
- Review and tighten LDAP group membership policies and monitor for unusual privilege escalations or access patterns.
- Employ strong authentication mechanisms and monitor LDAP credential usage to detect potential misuse.
- Conduct regular security audits of LDAP integration points and access control enforcement.
- Consider implementing additional layers of authorization checks outside of LDAP group membership to reduce risk.
- Educate administrators and developers about LDAP injection risks and secure coding practices related to LDAP queries.
- Use logging and alerting to detect anomalous LDAP queries that may indicate exploitation attempts.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.