CVE-2026-31835: dani-garcia vaultwarden · Insufficient Verification of Data Authenticity
Affects dani-garcia vaultwardenSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.35.5 when convenient.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.35.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade vaultwarden and dani-garcia/vaultwarden to 1.35.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dani-garciavaultwarden | Affected
| Fixed in
|
GitHubdani-garcia/vaultwardenpkg:github/dani-garcia/vaultwardenOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been fixed in Vaultwarden version 1.35.5. Users and administrators should upgrade to version 1.35.5 or later to remediate this issue. No other mitigation or workaround is indicated. Patch status is confirmed by the vendor's versioning information.
Description
Vaultwarden versions 1.35.4 and earlier contain a vulnerability in the WebAuthn authentication flow where persistent credential metadata flags are updated based on unverified authenticator data before signature validation. An attacker who knows a user's password but cannot produce a valid WebAuthn signature can modify these backup flags, causing a persistent denial of service for WebAuthn two-factor authentication on that user's credential. The issue is fixed in version 1.35.5.