Skip to main content
VulnerabilityPublished Updated

CVE-2026-31875: parse-server · Operation on a Resource after Expiration or Release

Affects parse-serverSource CVE Database V5

0

Not known to be exploited · CVSS 8.2 High : upgrade to 9.6.0-alpha.7 or 8.6.33 soon.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.7, 8.6.33
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.7 or 8.6.33; parse-community/parse-server to 8.6.33.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.7
Fixed in
  • 9.6.0-alpha.7
parse-communityparse-serverAffected
  • <8.6.33
Fixed in
  • 8.6.33
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.33
Fixed in
  • 8.6.33

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 9.6.0-alpha.7 or 8.6.33 or later, where the vulnerability is patched. Until upgrades are applied, administrators should consider invalidating all existing recovery codes and regenerating them to prevent reuse. Implement strict access controls and monitoring to detect unusual authentication patterns indicative of recovery code abuse. Educate users on safeguarding recovery codes and recognizing phishing attempts that could lead to code compromise. Additionally, consider implementing additional layers of authentication or anomaly detection to flag repeated use of recovery codes from unusual locations or devices. Regularly audit MFA configurations and recovery code usage logs to identify potential abuse. For deployments unable to upgrade immediately, disabling recovery codes temporarily or enforcing stricter MFA policies may reduce risk, though at the cost of user convenience.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.7 and 8.6.33, when multi-factor authentication (MFA) via TOTP is enabled for a user account, Parse Server generates two single-use recovery codes. These codes are intended as a fallback when the user cannot provide a TOTP token. However, recovery codes are not consumed after use, allowing the same recovery code to be used an unlimited number of times. This defeats the single-use design of recovery codes and weakens the security of MFA-protected accounts. An attacker who obtains a single recovery code can repeatedly authenticate as the affected user without the code ever being invalidated. This vulnerability is fixed in 9.6.0-alpha.7 and 8.6.33.

References

Community reviews

Loading reviews…