CVE-2026-31935: OISF suricata · Uncontrolled Resource Consumption
Affects OISF suricataSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 8.0.4 or 7.0.15 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.0.4, 7.0.15
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade suricata and oisf/suricata to 8.0.4 or 7.0.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OISFsuricata | Affected
| Fixed in
|
| OISFsuricata | Affected
| Fixed in
|
GitHuboisf/suricatapkg:github/oisf/suricataOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Suricata to version 7.0.15 or later, or to version 8.0.4 or later, where this vulnerability has been patched. No other mitigation is indicated or required.
Description
CVE-2026-31935 is a high-severity vulnerability in the OISF Suricata network IDS/IPS/NSM engine. It involves uncontrolled resource consumption caused by flooding crafted HTTP2 continuation frames, which can exhaust memory and typically cause the Suricata process to be terminated by the operating system. This issue affects Suricata versions prior to 7.0.15 and versions from 8.0.0 up to but not including 8.0.4. The vulnerability has been patched in versions 7.