CVE-2026-32269: parse-server · Function Call With Incorrect Order of Arguments
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 9.6.0-alpha.13 or 8.6.39 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.13, 8.6.39
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.13 or 8.6.39; parse-community/parse-server to 8.6.39.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should upgrade parse-server to versions 9.6.0-alpha.13 or 8.6.39 or later, where the issue is fixed. If immediate upgrade is not feasible, administrators should review and potentially disable the use of appidField and appIds configuration in the OAuth2 adapter to avoid triggering the flawed validation logic. Additionally, organizations should audit and harden the token introspection endpoint to strictly validate tokens and reject malformed requests without returning valid-looking data. Implementing strict input validation and logging on the introspection endpoint can help detect and prevent exploitation attempts. Monitoring authentication logs for unusual OAuth2 login failures or unexpected successful authentications from disallowed app contexts is recommended. Employing network-level protections such as IP whitelisting for introspection endpoint access and rate limiting can reduce attack surface. Finally, organizations should conduct thorough testing of OAuth2 authentication flows post-mitigation to ensure proper validation and functionality.
Description
CVE-2026-32269 is a medium severity vulnerability in parse-community's parse-server affecting versions prior to 9.6.0-alpha.13 and 8.6.39. The OAuth2 authentication adapter incorrectly validates app IDs when appidField and appIds are configured, sending malformed values to the token introspection endpoint instead of the user's actual access token. This flaw can cause OAuth2 logins to fail or, depending on the introspection endpoint's response, allow unauthorized authentication from disallowed app contexts. Exploitation does not require privileges or user interaction but has a high attack complexity. The vulnerability impacts deployments using the OAuth2 adapter with specific configurations and is fixed in the indicated patched versions.