Skip to main content
VulnerabilityPublished

CVE-2026-32270: craftcms commerce · Information Exposure

Affects craftcms commerceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 1.7 Low : upgrade to 5.6.0 or 4.11.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
1.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.6.0, 4.11.0, 5.5.5 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade commerce to 5.6.0 or 4.11.0; craftcms/commerce to 5.5.5 or 4.10.3.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=5.0.0 <5.6.0
Fixed in
  • 5.6.0
craftcmscommerceAffected
  • >=4.0.0 <4.11.0
Fixed in
  • 4.11.0
Packagistcraftcms/commercepkg:composer/craftcms/commerceOther threatsAffected
  • <4.10.3
  • <5.5.5
Fixed in
  • 4.10.3
  • 5.5.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Craft Commerce to version 4.11.0 or later, or 5.6.0 or later, where this vulnerability is fixed. No other mitigation is indicated or required as the fix is available in these versions.

Description

A vulnerability in Craft Commerce versions 4.0.0 through 4.10.2 and 5.0.0 through 5.5.4 allows exposure of sensitive order information to unauthenticated users. The PaymentsController::actionPay endpoint discloses serialized order data, including customer email and addresses, when an order number is provided and the email verification fails during an anonymous payment attempt.

References

Community reviews

Loading reviews…