CVE-2026-32276: opensource-workshop connect-cms · Code Injection
Affects opensource-workshop connect-cmsSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.41.1 or 1.41.1 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.41.1, 1.41.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade connect-cms to 2.41.1 or 1.41.1; opensource-workshop/connect-cms to 1.41.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| opensource-workshopconnect-cms | Affected
| Fixed in
|
GitHubopensource-workshop/connect-cmspkg:github/opensource-workshop/connect-cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Upgrade Connect-CMS installations to version 1.41.1 or 2.41.1 immediately to apply the official patch addressing this vulnerability. 2. Restrict authenticated user permissions to the minimum necessary, especially limiting access to the Code Study Plugin or disabling it if not required. 3. Implement strict input validation and sanitization controls on any user-supplied data processed by plugins or custom code to prevent code injection. 4. Monitor logs and system behavior for unusual activities related to code execution or plugin usage, including unexpected process spawning or file modifications. 5. Employ web application firewalls (WAFs) with custom rules to detect and block suspicious payloads targeting the Code Study Plugin. 6. Conduct regular security audits and penetration testing focusing on plugin components and user privilege management. 7. Educate users about the risks of privilege misuse and enforce strong authentication mechanisms to reduce the risk of compromised credentials. 8. Isolate Connect-CMS servers in segmented network zones to limit lateral movement in case of compromise.
Description
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, an authenticated user may be able to execute arbitrary code in the Code Study Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
References
- github.com/opensource-workshop/connect-cms/security/advisories/GHSA-hxqw-6qv7-cqfv (opens in a new tab)
- github.com/opensource-workshop/connect-cms/commit/c0bcd07fc1e9375941aa1295d044328ecd44ed85 (opens in a new tab)
- github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1 (opens in a new tab)
- github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1 (opens in a new tab)