Skip to main content
VulnerabilityPublished

CVE-2026-32277: opensource-workshop connect-cms · Cross-site Scripting

Affects opensource-workshop connect-cmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 2.41.1 or 1.41.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.41.1, 1.41.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade opensource-workshop connect-cms to 2.41.1 or 1.41.1.

Affected software

ProductAffectedFixed in
opensource-workshopconnect-cmsAffected
  • >=2.35.0 <2.41.1
Fixed in
  • 2.41.1
opensource-workshopconnect-cmsAffected
  • >=1.35.0 <1.41.1
Fixed in
  • 1.41.1
GitHubopensource-workshop/connect-cmspkg:github/opensource-workshop/connect-cmsOther threatsAffected
  • 1.35.0 <=1.41.0
  • 2.35.0 <=2.41.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-32277, organizations should immediately upgrade Connect-CMS to versions 1.41.1 or 2.41.1 where the vulnerability is patched. Additionally, administrators should audit the use of the Cabinet Plugin and restrict its usage if not necessary. Implement Content Security Policy (CSP) headers to reduce the impact of potential XSS by restricting script execution sources. Conduct user training to raise awareness about phishing and social engineering attacks that could trigger exploitation. Regularly review and sanitize all user inputs and outputs in custom plugins or extensions to prevent similar vulnerabilities. Employ web application firewalls (WAFs) with rules targeting DOM-based XSS patterns to provide an additional layer of defense. Monitor logs for unusual activities related to the Cabinet Plugin or unexpected script execution. Finally, maintain a robust patch management process to ensure timely application of security updates.

Description

Connect-CMS is a content management system. In versions 1.35.0 through 1.41.0 and 2.35.0 through 2.41.0, a DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Versions 1.41.1 and 2.41.1 contain a patch.

References

Community reviews

Loading reviews…