Skip to main content
VulnerabilityPublished

CVE-2026-3229: wofSSL wolfSSL · Heap-based Buffer Overflow

Affects wofSSL wolfSSLSource CVE Database V5

0
Compare

Public exploit available · CVSS 1.2 Low : upgrade to 5.9.0 as a priority.

Data as of 1 Nov 2026, 08:20 UTC

CVSS 4.0 base score
1.2Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.06% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.9.0
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/U:Green

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade wofSSL wolfSSL to 5.9.0.

Affected software

ProductAffectedFixed in
wofSSLwolfSSLAffected
  • <5.9.0
Fixed in
  • 5.9.0
GitHubwolfssl/wolfsslpkg:github/wolfssl/wolfsslOther threatsAffected
  • =0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should audit their use of wolfSSL, particularly verifying whether third-party compatibility features (enable-opensslall, enable-opensslextra, enable-lighty, enable-stunnel, enable-nginx, enable-haproxy) are enabled, as these activate the vulnerable APIs. If these features are not required, disabling them can reduce exposure. For applications that must use these features, ensure strict access controls and integrity protections around certificate loading contexts to prevent local compromise. Monitor and restrict local access to systems running wolfSSL to trusted administrators only. Implement runtime protections such as heap integrity checks, address space layout randomization (ASLR), and control flow integrity (CFI) to mitigate exploitation impact. Stay alert for official patches or updates from wolfSSL and apply them promptly once available. Additionally, conduct thorough testing of certificate handling workflows to detect anomalies or crashes that might indicate exploitation attempts. Consider using alternative TLS libraries if timely patches are unavailable and risk is unacceptable.

Description

An integer overflow vulnerability existed in the static function wolfssl_add_to_chain, that caused heap corruption when certificate data was written out of bounds of an insufficiently sized certificate buffer.wolfssl_add_to_chain is called by these API: wolfSSL_CTX_add_extra_chain_cert, wolfSSL_CTX_add1_chain_cert, wolfSSL_add0_chain_cert. These API are enabled for 3rd party compatibility features: enable-opensslall, enable-opensslextra, enable-lighty, enable-stunnel, enable-nginx, enable-haproxy. This issue is not remotely exploitable, and would require that the application context loading certificates is compromised.

References

Community reviews

Loading reviews…