CVE-2026-32300: opensource-workshop connect-cms · Improper Authorization
Affects opensource-workshop connect-cmsSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 2.41.1 or 1.41.1 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.41.1, 1.41.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade connect-cms and opensource-workshop/connect-cms to 2.41.1 or 1.41.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| opensource-workshopconnect-cms | Affected
| Fixed in
|
| opensource-workshopconnect-cms | Affected
| Fixed in
|
GitHubopensource-workshop/connect-cmspkg:github/opensource-workshop/connect-cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-32300, organizations should immediately upgrade Connect-CMS to version 1.41.1 or 2.41.1 or later, where the vulnerability has been patched. In addition to patching, administrators should audit user permissions and roles to ensure the principle of least privilege is enforced, minimizing the risk of unauthorized access. Implementing robust monitoring and logging of profile update activities can help detect suspicious modifications. Employing web application firewalls (WAFs) with custom rules to detect anomalous requests targeting profile update endpoints may provide temporary protection. Regular security assessments and code reviews of custom plugins or integrations with Connect-CMS are recommended to prevent similar authorization flaws. Organizations should also educate users about the importance of strong authentication and consider multi-factor authentication (MFA) to reduce risk from compromised credentials. Finally, maintaining an incident response plan tailored to CMS compromise scenarios will improve readiness in case of exploitation.
Description
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, an improper authorization issue in the My Page profile update feature may allow modification of arbitrary user information. Versions 1.41.1 and 2.41.1 contain a patch.
References
- github.com/opensource-workshop/connect-cms/security/advisories/GHSA-qr6x-wvxr-8hm9 (opens in a new tab)
- github.com/opensource-workshop/connect-cms/commit/7c9951738c62a1d51b91e9956d1eb756c5d52cce (opens in a new tab)
- github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1 (opens in a new tab)
- github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1 (opens in a new tab)