CVE-2026-32304: locutusjs locutus · Code Injection
Affects locutusjs locutusSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.0.14 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade locutus and locutusjs/locutus to 3.0.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| locutusjslocutus | Affected
| Fixed in
|
npmlocutusjs/locutuspkg:npm/locutusjs/locutusOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available in locutus version 3.0.14. Users should upgrade to version 3.0.14 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
Locutus brings stdlibs of other programming languages to JavaScript for educational purposes. Prior to 3.0.14, the create_function(args, code) function passes both parameters directly to the Function constructor without any sanitization, allowing arbitrary code execution. This is distinct from CVE-2026-29091 which was call_user_func_array using eval() in v2.x. This finding affects create_function using new Function() in v3.x. This vulnerability is fixed in 3.0.14.
References
- github.com/locutusjs/locutus/security/advisories/GHSA-vh9h-29pq-r5m8 (opens in a new tab)
- github.com/locutusjs/locutus/releases/tag/v3.0.14 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-32304 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2447200 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32304.json (opens in a new tab)