CVE-2026-32327: Apache Portable Runtime Utility · Uncontrolled Recursion
Affects Apache Portable Runtime UtilitySource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 1.6.4 : patch Apache Portable Runtime Utility as a priority.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Portable Runtime Utility | Affected
| Fixed in– |
AI-suggested
Users should upgrade Apache Portable Runtime Utility to version 1.6.4 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the available data. Patch status is confirmed by the vendor's recommendation to upgrade.
Description
CVE-2026-32327 is a critical vulnerability in Apache Portable Runtime Utility (APR-util) versions 1.6.3 and earlier. It involves uncontrolled recursion in the apr_xml_quote_elem() function, which can be triggered by parsing XML from untrusted sources. This flaw allows a stack recursion attack that can cause denial of service. The issue is fixed in version 1.6.4.