CVE-2026-32599: gravitl netmaker · SQL Injection
Affects gravitl netmakerSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.5.0 when convenient.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade netmaker and gravitl/netmaker to 1.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| gravitlnetmaker | Affected
| Fixed in
|
GitHubgravitl/netmakerpkg:github/gravitl/netmakerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to netmaker version 1.5.0 or later, where the vulnerability is fixed. No other mitigation is required as the issue is resolved in the official patch.
Description
CVE-2026-32599 is a medium severity SQL injection vulnerability in gravitl netmaker prior to version 1.5.0. The issue arises from the sqliteDeleteRecord function, which constructs SQL DELETE statements using direct string concatenation of user input, allowing an authenticated attacker to perform boolean-based SQL injection. This vulnerability is fixed in version 1.5.0.