Skip to main content
VulnerabilityPublished Updated

CVE-2026-29195: gravitl netmaker · Incorrect Authorization

Affects gravitl netmakerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.5.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade netmaker and gravitl/netmaker to 1.5.0.

Affected software

ProductAffectedFixed in
gravitlnetmakerAffected
  • <1.5.0
Fixed in
  • 1.5.0
GitHubgravitl/netmakerpkg:github/gravitl/netmakerOther threatsAffected
  • <1.5.0
Fixed in
  • 1.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations should immediately upgrade netmaker to version 1.5.0 or later, where the authorization checks have been corrected. Until upgrading is possible, restrict admin user privileges to only trusted personnel and monitor admin activities closely for suspicious role assignment attempts. Implement strict access controls and audit logging on the user update API endpoint to detect unauthorized privilege escalations. Employ network segmentation and multi-factor authentication (MFA) for admin accounts to reduce the risk of credential compromise. Additionally, conduct regular reviews of user roles and permissions within netmaker to ensure no unauthorized super-admin assignments exist. Consider deploying runtime application self-protection (RASP) or web application firewalls (WAF) with custom rules to detect and block anomalous API requests attempting to assign super-admin roles. Finally, educate administrators on the risks of privilege escalation and enforce the principle of least privilege in all network management operations.

Description

Netmaker makes networks with WireGuard. Prior to version 1.5.0, the user update handler (PUT /api/users/{username}) lacks validation to prevent an admin-role user from assigning the super-admin role during account updates. While the code correctly blocks an admin from assigning the admin role to another user, it does not include an equivalent check for the super-admin role. This issue has been patched in version 1.5.0.

References

Community reviews

Loading reviews…