Skip to main content
VulnerabilityPublished

CVE-2026-32609: nicolargo glances · Information Exposure

Affects nicolargo glancesSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 4.5.2 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade glances and nicolargo/glances to 4.5.2.

Affected software

ProductAffectedFixed in
nicolargoglancesAffected
  • <4.5.2
Fixed in
  • 4.5.2
GitHubnicolargo/glancespkg:github/nicolargo/glancesOther threatsAffected
  • <4.5.2
Fixed in
  • 4.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-32609, organizations should immediately upgrade all Glances installations to version 4.5.2 or later, where the vulnerability is fully addressed by securing the /api/v4/args endpoints and redacting sensitive information. Until upgrades can be performed, administrators should enable the --password option to enforce authentication on the API endpoints, preventing unauthenticated access. Additionally, network-level controls such as firewall rules or VPNs should be used to restrict access to Glances API endpoints to trusted users only. Monitoring and logging access to these endpoints can help detect any unauthorized attempts. It is also advisable to rotate any exposed credentials, such as SNMP community strings and password hashes, if there is suspicion of compromise. Reviewing and minimizing the exposure of monitoring tools like Glances on public or untrusted networks reduces attack surface. Finally, organizations should audit their use of Glances and ensure that sensitive configuration data is not unnecessarily exposed through APIs or logs.

Description

Glances is an open-source system cross-platform monitoring tool. The GHSA-gh4x fix (commit 5d3de60) addressed unauthenticated configuration secrets exposure on the `/api/v4/config` endpoints by introducing `as_dict_secure()` redaction. However, the `/api/v4/args` and `/api/v4/args/{item}` endpoints were not addressed by this fix. These endpoints return the complete command-line arguments namespace via `vars(self.args)`, which includes the password hash (salt + pbkdf2_hmac), SNMP community strings, SNMP authentication keys, and the configuration file path. When Glances runs without `--password` (the default), these endpoints are accessible without any authentication. Version 4.5.2 provides a more complete fix.

References

Community reviews

Loading reviews…