Skip to main content
VulnerabilityPublished Updated

CVE-2026-32641: parseablehq parseable · Uncaught Exception

Affects parseablehq parseableSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.0.0 soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade parseable and github.com/parseablehq/parseable to 3.0.0.

Affected software

ProductAffectedFixed in
parseablehqparseableAffected
  • <3.0.0
Fixed in
  • 3.0.0
Gogithub.com/parseablehq/parseablepkg:golang/github.com/parseablehq/parseableOther threatsAffected
  • <3.0.0
Fixed in
  • 3.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Parseable version 3.0.0 or later, where this issue is fixed. No other mitigation is required as the fix is official and available.

Description

Parseable is a log analytics platform built for high-volume data ingestion and analysis. Prior to 3.0.0, src/handlers/http/middleware.rs uses unwrap() while parsing the x-amz-firehose-common-attributes header before authentication. A remote unauthenticated attacker can supply non-UTF-8 header data, malformed JSON, or invalid derived header values that trigger a Rust panic and interrupt request handling, allowing repeated requests to deny service or cause container restart loops. This issue is fixed in version 3.0.0.

References

Community reviews

Loading reviews…