Skip to main content
VulnerabilityPublished Updated

CVE-2026-32707: PX4-Autopilot · Stack-based Buffer Overflow

Affects PX4-AutopilotSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.2 Medium : upgrade to 1.17.0-rc2 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.17.0-rc2
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PX4-Autopilot to 1.17.0-rc2.

Affected software

ProductAffectedFixed in
PX4PX4-AutopilotAffected
  • <1.17.0-rc2
Fixed in
  • 1.17.0-rc2
GitHubpx4/PX4-Autopilotpkg:github/px4/PX4-AutopilotOther threatsAffected
  • =1.17.0-rc2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-32707, organizations should immediately upgrade PX4-Autopilot to version 1.17.0-rc2 or later, where the vulnerability is patched. If upgrading is not immediately feasible, disabling the tattu_can module can reduce exposure, provided that this does not impair critical functionality. Network segmentation and physical security controls should be enforced to prevent unauthorized access to the CAN bus, limiting the ability of attackers to inject malicious frames. Employing CAN bus message authentication or encryption, if supported, can further reduce risk. Regularly auditing drone firmware versions and configurations will help ensure vulnerable versions are not in use. Additionally, monitoring drone behavior for anomalies indicative of memory corruption or crashes can provide early warning of exploitation attempts. Developers should review other CAN-related code for similar unbounded memory operations to prevent future vulnerabilities.

Description

PX4 autopilot is a flight control solution for drones. Prior to 1.17.0-rc2, tattu_can contains an unbounded memcpy in its multi-frame assembly loop, allowing stack memory overwrite when crafted CAN frames are processed. In deployments where tattu_can is enabled and running, a CAN-injection-capable attacker can trigger a crash (DoS) and memory corruption. This vulnerability is fixed in 1.17.0-rc2.

References

Community reviews

Loading reviews…