Skip to main content
VulnerabilityPublished

CVE-2026-32722: bloomberg memray · Cross-site Scripting

Affects bloomberg memraySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.6 Low : upgrade to 1.19.2 when convenient.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
3.6Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.19.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade bloomberg memray to 1.19.2.

Affected software

ProductAffectedFixed in
bloombergmemrayAffected
  • <1.19.2
Fixed in
  • 1.19.2
PyPImemraypkg:pypi/memrayOther threatsAffected
  • <1.19.2
Fixed in
  • 1.19.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-32722, organizations should upgrade Memray to version 1.19.2 or later, where the vulnerability is fixed by proper escaping of command line arguments in HTML reports. Until upgrading, avoid opening Memray-generated HTML reports from untrusted or unknown sources. Implement strict access controls to limit who can run Memray profiling on systems, reducing the risk of attacker-controlled command line arguments. Incorporate security reviews of profiling reports before sharing or opening them in browsers. Consider sandboxing or isolating environments where Memray reports are viewed to limit potential script execution impact. Educate developers and operations teams about the risk of opening profiling reports from untrusted inputs. Additionally, integrate Memray usage into broader application security and development lifecycle controls to detect and prevent injection of malicious inputs into profiling tools.

Description

CVE-2026-32722 is a cross-site scripting (XSS) vulnerability in Bloomberg's Memray, a Python memory profiler. Versions prior to 1.19.2 render command line arguments directly into HTML reports without proper escaping, allowing attacker-controlled input to execute JavaScript when the report is viewed in a browser. The vulnerability requires local access to generate a report with malicious input and user interaction to open the report. The CVSS score is 3.6 (low severity) due to limited impact and exploitation complexity. No known exploits are currently reported in the wild. The issue is fixed in Memray version 1.19.

References

Community reviews

Loading reviews…