CVE-2026-32794: Apache Airflow Provider for Databricks · Improper Certificate Validation
Affects Apache Airflow Provider for DatabricksSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 1.12.0 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.12.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache Airflow Provider for Databricks and apache-airflow-provider-databricks to 1.12.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow Provider for Databricks | Affected
| Fixed in
|
PyPIapache-airflow-provider-databrickspkg:pypi/apache-airflow-provider-databricksOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade the Apache Airflow Provider for Databricks to version 1.12.0 or later, where this improper certificate validation vulnerability has been fixed. No other mitigation or temporary workaround is indicated. Patch status is confirmed by the vendor advisory recommending the upgrade.
Description
CVE-2026-32794 is an improper certificate validation vulnerability in the Apache Airflow Provider for Databricks versions from 1.10.0 before 1.12.0. The provider did not validate certificates for connections to the Databricks back-end, which could allow a man-in-the-middle attacker to intercept or manipulate traffic or exfiltrate credentials without detection. The issue is fixed in version 1.12.0. The vulnerability has a CVSS score of 4.