CVE-2026-45781: modelcontextprotocol registry · Failing Open
Affects modelcontextprotocol registrySource CVE Database V5
Not known to be exploited · CVSS 3.5 Low : upgrade to 1.7.9 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade modelcontextprotocol registry to 1.7.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| modelcontextprotocolregistry | Affected
| Fixed in
|
AI-suggested
Upgrade the MCP Registry to version 1.7.9 or later, where this vulnerability is fixed. Prior to upgrading, be aware that the registry fails open on HTTP 429 responses from the upstream OCI registry, allowing ownership validation bypass. No other mitigations are documented. Patch status is not explicitly stated but the fix is included in version 1.7.9.
Description
CVE-2026-45781 is a vulnerability in the modelcontextprotocol (MCP) registry prior to version 1.7.9. The issue arises because the OCI ownership validation fails open when the upstream OCI registry returns an HTTP 429 (Too Many Requests) response. This failure allows any authenticated publisher to bind namespaces they do not control to OCI images, bypassing the critical label-match ownership check. The vulnerability is specific to OCI packages; other package types enforce stricter validation. This flaw has a low severity score and no known exploits in the wild. A fix was introduced in version 1.7.9.