CVE-2026-3282: libvips · Out-of-bounds Read
Affects libvipsSource CVE Database V5
Public exploit available · CVSS 4.8 Medium.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 27 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| libvips | Affected
| Fixed in– |
GitHublibvips/libvipspkg:github/libvips/libvipsOther threats | Affected
| Fixed in– |
CPE configurations (1)
cpe:2.3:a:libvips:libvips:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-3282, organizations should immediately apply the official patch identified by commit 7215ead1e0cd7d3703cc4f5fca06d7d0f4c22b91 or upgrade libvips to a version later than 8.19.0 that includes the fix. It is critical to verify that all instances of libvips in the environment are updated, including those embedded within third-party applications. Restrict local access to trusted users only, and implement strict access controls and monitoring to detect unauthorized local activity. Employ application sandboxing or containerization to limit the impact of potential exploitation. Regularly audit and monitor logs for unusual behavior related to image processing functions. Additionally, consider employing memory protection mechanisms such as Address Space Layout Randomization (ASLR) and Data Execution Prevention (DEP) to reduce exploitation likelihood. Finally, maintain an up-to-date inventory of software dependencies to quickly identify and remediate vulnerable versions.
Description
A flaw has been found in libvips 8.19.0. This vulnerability affects the function vips_unpremultiply_build of the file libvips/conversion/unpremultiply.c. Executing a manipulation of the argument alpha_band can lead to out-of-bounds read. The attack needs to be launched locally. The exploit has been published and may be used. This patch is called 7215ead1e0cd7d3703cc4f5fca06d7d0f4c22b91. A patch should be applied to remediate this issue.
References
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- github.com/libvips/libvips/issues/4881 (opens in a new tab)
- github.com/libvips/libvips/pull/4886 (opens in a new tab)
- github.com/libvips/libvips/issues/4881 (opens in a new tab)
- github.com/libvips/libvips/commit/7215ead1e0cd7d3703cc4f5fca06d7d0f4c22b91 (opens in a new tab)
- github.com/libvips/libvips/ (opens in a new tab)