Skip to main content
VulnerabilityPublished Updated

CVE-2026-32829: PSeitz lz4_flex · Insertion of Sensitive Information Into Sent Data

Affects PSeitz lz4_flexSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 0.12.1 or 0.11.6 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.12.1, 0.11.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade lz4_flex to 0.12.1 or 0.11.6; github/PSeitz/lz4_flex to 0.11.6.

Affected software

ProductAffectedFixed in
PSeitzlz4_flexAffected
  • >=0.12.0 <0.12.1
Fixed in
  • 0.12.1
PSeitzlz4_flexAffected
  • <0.11.6
Fixed in
  • 0.11.6
crates.iogithub/PSeitz/lz4_flexpkg:cargo/github/PSeitz/lz4_flexOther threatsAffected
  • <0.11.6
  • =0.12.0
Fixed in
  • 0.11.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in lz4_flex versions 0.11.6 and 0.12.1. Users should upgrade to these or later versions to remediate the vulnerability. Red Hat advises that in their RHEL 9 and 10 products, the risk is minimal and exploitation requires local access and privileges, so no additional mitigation is necessary beyond applying the update. Users should ensure that block-based API functions do not process untrusted data with safe-decode disabled.

Description

lz4_flex is a pure Rust implementation of LZ4 compression/decompression. In versions 0.11.5 and below, and 0.12.0, decompressing invalid LZ4 data can leak sensitive information from uninitialized memory or from previous decompression operations. The library fails to properly validate offset values during LZ4 "match copy operations," allowing out-of-bounds reads from the output buffer. The block-based API functions (`decompress_into`, `decompress_into_with_dict`, and others when `safe-decode` is disabled) are affected, while all frame APIs are unaffected. The impact is potential exposure of sensitive data and secrets through crafted or malformed LZ4 input. This issue has been fixed in versions 0.11.6 and 0.12.1.

References

Community reviews

Loading reviews…