CVE-2026-32870: getkirby kirby · XML Injection
Affects getkirby kirbySource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 5.4.0 or 4.9.0 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.4.0, 4.9.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade kirby and getkirby/kirby to 5.4.0 or 4.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| getkirbykirby | Affected
| Fixed in
|
| getkirbykirby | Affected
| Fixed in
|
GitHubgetkirby/kirbypkg:github/getkirby/kirbyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been patched in Kirby versions 4.9.0 and 5.4.0. Users should upgrade to at least these versions to remediate the issue. Sites or plugins that do not use the vulnerable XML generation methods are not affected and require no action. Patch status is not explicitly stated beyond the version fixes; therefore, verify with the official Kirby release notes for confirmation.
Description
CVE-2026-32870 is an XML Injection vulnerability in the getkirby CMS affecting versions prior to 4.9.0 and between 5.0.0 and before 5.4.0. The issue arises from improper handling of CDATA blocks in the Xml::value() method, allowing structured data outside valid CDATA blocks to bypass escaping protections. This vulnerability can be exploited if site or plugin code uses the vulnerable XML generation methods to create XML strings from input data, potentially enabling manipulation of systems that process these XML files. The vulnerability does not affect Kirby core functionality or sites that do not use XML generation in site or plugin code.