Skip to main content
VulnerabilityPublished

CVE-2026-33317: OP-TEE optee_os · Out-of-bounds Read

Affects OP-TEE optee_osSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High · fixed in 4.11.0 : patch OP-TEE optee_os soon.

Data as of 30 Oct 2026, 11:34 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.11.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
OP-TEEoptee_osAffected
  • >=3.13.0 <=4.10.0
Fixed in–
GitHubop-tee/optee_ospkg:github/op-tee/optee_osOther threatsAffected
  • =3.13.0 <=4.10.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Patches addressing this vulnerability have been committed and are anticipated to be included in OP-TEE version 4.11.0. Users should upgrade to version 4.11.0 or later once available. Until then, monitor the vendor advisory for official patch releases and avoid supplying untrusted input to the PKCS#11 TA interface.

Description

CVE-2026-33317 is a high-severity vulnerability in OP-TEE's optee_os affecting versions 3.13.0 through 4.10.0. It involves an out-of-bounds read and write in the PKCS#11 Trusted Application due to missing checks in the entry_get_attribute_value() function. This flaw can cause reading up to 7 bytes beyond a buffer's end and writing beyond the buffer with attribute data, potentially leading to information disclosure, integrity compromise, or a crash. Patches addressing this issue are included in commits expected to be part of version 4.11.0.

References

Community reviews

Loading reviews…