Skip to main content
VulnerabilityPublished

CVE-2026-32873: vshakitskiy ewe · Expired Pointer Dereference

Affects vshakitskiy eweSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.0.5 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.5, 3.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ewe to 3.0.5; vshakitskiy/ewe to 3.0.0.

Affected software

ProductAffectedFixed in
vshakitskiyeweAffected
  • >=0.8.0 <3.0.5
Fixed in
  • 3.0.5
GitHubvshakitskiy/ewepkg:github/vshakitskiy/eweOther threatsAffected
  • <3.0.0
Fixed in
  • 3.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The most effective mitigation is to upgrade all affected 'ewe' web server instances to version 3.0.5 or later, where the vulnerability is fixed. Until upgrade is possible, organizations should consider implementing network-level protections such as Web Application Firewalls (WAFs) or Intrusion Prevention Systems (IPS) configured to detect and block suspicious chunked transfer encoding requests with malformed or forbidden trailer headers. Rate limiting and IP reputation filtering can help reduce exposure to automated exploitation attempts. Monitoring BEAM process CPU usage and setting alerts for abnormal spikes can enable early detection of exploitation attempts. Additionally, isolating vulnerable servers behind reverse proxies or load balancers that can sanitize HTTP requests may reduce attack surface. Application developers should avoid relying on application-level workarounds, as the vulnerability triggers before application code execution. Finally, maintain up-to-date threat intelligence feeds to stay informed about emerging exploits targeting this vulnerability.

Description

CVE-2026-32873 is a high-severity vulnerability in the Gleam web server 'ewe' versions 0.8.0 through 3.0.4. The flaw exists in the handle_trailers function, where rejected trailer headers cause an infinite recursion loop, leading to 100% CPU usage and a denial-of-service condition. This occurs because the function repeatedly re-parses the same header without advancing, permanently wedging the BEAM process. Exploitation requires no authentication or user interaction and can be triggered remotely via chunked HTTP requests. The vulnerability is fixed in version 3.0.

References

Community reviews

Loading reviews…