Skip to main content
VulnerabilityPublished

CVE-2026-32878: parse-server · Prototype Pollution

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 9.6.0-alpha.20 or 8.6.44 when convenient.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.20, 8.6.44
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.20 or 8.6.44; parse-community/parse-server to 8.6.44.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.20
Fixed in
  • 9.6.0-alpha.20
parse-communityparse-serverAffected
  • <8.6.44
Fixed in
  • 8.6.44
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.44
Fixed in
  • 8.6.44

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary and only effective mitigation is to upgrade parse-server to version 9.6.0-alpha.20 or later, or 8.6.44 or later, where the vulnerable deep copy library has been replaced with a secure built-in deep clone mechanism. Organizations should audit their parse-server deployments to identify affected versions and prioritize patching. Since no workarounds exist, temporary mitigation measures such as network segmentation, strict access controls, and monitoring for anomalous schema modification requests may help reduce exposure but do not eliminate the risk. Developers should review application code for any custom deep copy or cloning utilities that might be vulnerable to prototype pollution and replace them with secure alternatives. Additionally, implementing runtime protections such as input validation and anomaly detection on API requests targeting schema modifications can help detect exploitation attempts. Regular backups of schema and data are critical to enable recovery if schema corruption occurs. Finally, security teams should monitor vendor advisories and community forums for any emerging exploit techniques or patches.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0 and 8.6.44, an attacker can bypass the default request keyword denylist protection and the class-level permission for adding fields by sending a crafted request that exploits prototype pollution in the deep copy mechanism. This allows injecting fields into class schemas that have field addition locked down, and can cause permanent schema type conflicts that cannot be resolved even with the master key. In 9.6.0 and 8.6.44, the vulnerable third-party deep copy library has been replaced with a built-in deep clone mechanism that handles prototype properties safely, allowing the existing denylist check to correctly detect and reject the prohibited keyword. No known workarounds are available.

References

Community reviews

Loading reviews…