Skip to main content
VulnerabilityPublished Updated

CVE-2026-32893: chamilo-lms · Cross-site Scripting

Affects chamilo-lmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 2.0.0-RC.3 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.0-RC.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade chamilo-lms to 2.0.0-RC.3.

Affected software

ProductAffectedFixed in
chamilochamilo-lmsAffected
  • >=2.0.0-alpha.1 <2.0.0-RC.3
Fixed in
  • 2.0.0-RC.3
GitHubchamilo/chamilo-lmspkg:github/chamilo/chamilo-lmsOther threatsAffected
  • =2.0.0-RC.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Chamilo LMS to version 2.0.0-RC.3 or later, where this vulnerability is fixed. Since this is a software vulnerability in a self-hosted product, patching by updating the software is the recommended remediation. Patch status is not explicitly stated but the fix is included in version 2.0.0-RC.3, so upgrading to this or a later version mitigates the issue.

Description

Chamilo LMS is a learning management system. Prior to 2.0.0-RC.3, a Reflected Cross-Site Scripting (XSS) vulnerability in the exercise question list admin panel allows an attacker to execute arbitrary JavaScript in an authenticated teacher's browser. The pagination code merges all $_GET parameters via array_merge() and outputs the result via http_build_query() directly into HTML href attributes without htmlspecialchars() encoding. This vulnerability is fixed in 2.0.0-RC.3.

References

Community reviews

Loading reviews…