CVE-2026-32933: LuckyPennySoftware AutoMapper · Uncontrolled Recursion
Affects LuckyPennySoftware AutoMapperSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 16.1.1 or 15.1.1 soon.
Data as of 1 Nov 2026, 08:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.1.1, 15.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade AutoMapper and automapper to 16.1.1 or 15.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LuckyPennySoftwareAutoMapper | Affected
| Fixed in
|
| LuckyPennySoftwareAutoMapper | Affected
| Fixed in
|
NuGetautomapperpkg:nuget/automapperOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-32933, organizations should immediately upgrade AutoMapper to versions 15.1.1 or 16.1.1, where the vulnerability is fixed. If upgrading is not immediately feasible, implement input validation and sanitization to restrict the depth and complexity of object graphs processed by AutoMapper, thereby preventing excessive recursion. Developers should audit application code to identify all usage points of AutoMapper and ensure that untrusted or user-supplied data is not mapped without validation. Employ runtime monitoring and alerting for StackOverflowException or application crashes to detect potential exploitation attempts. Consider implementing circuit breakers or fallback mechanisms to maintain service availability during failures. Finally, maintain an inventory of .NET dependencies and apply timely patch management practices to reduce exposure to similar vulnerabilities.
Description
CVE-2026-32933 is a high-severity vulnerability in LuckyPennySoftware's AutoMapper library for . NET, affecting versions prior to 15.1.1 and between 16.0.0 and 16.1.1. The flaw arises from uncontrolled recursion when mapping deeply nested object graphs, leading to stack exhaustion and a StackOverflowException that crashes the application process. This Denial of Service (DoS) vulnerability requires no authentication or user interaction and can be triggered remotely by supplying crafted input.
References
- github.com/LuckyPennySoftware/AutoMapper/security/advisories/GHSA-rvv3-g6hj-g44x (opens in a new tab)
- github.com/LuckyPennySoftware/AutoMapper/commit/0afaf1e91648fca1a57512e94dd00a76ee016816 (opens in a new tab)
- github.com/LuckyPennySoftware/AutoMapper/releases/tag/v15.1.1 (opens in a new tab)
- github.com/LuckyPennySoftware/AutoMapper/releases/tag/v16.1.1 (opens in a new tab)