CVE-2026-32944: parse-server · Uncontrolled Recursion
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 9.6.0-alpha.21 or 8.6.45 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.21, 8.6.45
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.21 or 8.6.45; parse-server to 8.6.45.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade parse-server to version 9.6.0-alpha.21 or later, or 8.6.45 or later, where the fix is implemented. After upgrading, administrators must explicitly enable and configure the requestComplexity.queryDepth option to enforce a sensible maximum depth for query condition nesting based on their application's expected query complexity. This setting prevents maliciously crafted requests from triggering uncontrolled recursion. It is critical to test this configuration in staging environments to avoid breaking legitimate queries. Network-level protections such as Web Application Firewalls (WAFs) can be tuned to detect and block requests with suspiciously deep or complex query structures, providing an additional layer of defense. Monitoring and alerting on parse-server crashes or unusual request patterns can help detect exploitation attempts early. Since no workarounds exist, patching and configuration are the only effective defenses. Organizations should also review their incident response plans to handle potential DoS incidents and ensure rapid recovery.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0 and 8.6.45, an unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients. Starting in version 9.6.0 and 8.6.45, a depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app. No known workarounds are available.