Skip to main content
VulnerabilityPublished Updated

CVE-2026-33007: Apache HTTP Server · NULL Pointer Dereference

Affects Apache HTTP ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • >=2.4.0 <=2.4.66
Fixed in–

AI-suggested

Users should upgrade to Apache HTTP Server version 2.4.67, which contains the fix for this vulnerability. Patch status is confirmed by the vendor recommendation to upgrade. No alternative mitigations are specified.

Description

CVE-2026-33007 is a medium severity vulnerability in Apache HTTP Server versions 2.4.66 and earlier. It involves a NULL pointer dereference in the mod_authn_socache module that can be triggered by an unauthenticated remote user. This flaw allows crashing a child process when the server is configured as a caching forward proxy. The issue does not impact confidentiality or integrity but causes a denial of service by affecting availability. Users are advised to upgrade to Apache HTTP Server version 2.4.67, which addresses this vulnerability.

References

Community reviews

Loading reviews…