Skip to main content
VulnerabilityPublished Updated

CVE-2026-33017: langflow · Code Injection

Affects langflowSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Exploited in the wild · KEV due 8 Apr 2026 · public exploit available (Metasploit, Exploit-DB) · 96% EPSS : upgrade to 1.9.0 now.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
EPSS
96.1% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  3. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by GitHub, Inc.

    , 3 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 31 minutes after disclosure

  4. , 5 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 19 days after disclosure

  6. , 110 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade langflow and langflow-ai/langflow to 1.9.0.

Affected software

ProductAffectedFixed in
langflow-ailangflowAffected
  • <1.9.0
Fixed in
  • 1.9.0
GitHublangflow-ai/langflowpkg:github/langflow-ai/langflowOther threatsAffected
  • <1.9.0
Fixed in
  • 1.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2026-33017 is a critical unauthenticated remote code execution vulnerability in langflow versions prior to 1.9.0. The vulnerability exists in the POST /api/v1/build_public_tmp/{flow_id}/flow endpoint, which allows building public flows without authentication. When the optional data parameter is supplied, attacker-controlled flow data containing arbitrary Python code is executed via exec() without sandboxing. This flaw enables attackers to execute arbitrary code remotely without any privileges. The issue was fixed in langflow version 1.9.0.

References

Community reviews

Loading reviews…